• Все разделы
  • Статьи
  • Медиа
  • Новости
  • Нормативные материалы
  • Конференции
  • Глоссарий

Переполнение буфера

Карточка уязвимости

Характеристики уязвимости

Уровень опасности
Оценка CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Производитель ПО
Наименование ПО
TightVNC Server (1.0.0, 1.3.10) TightVNC Viewer (1.0.0, 1.3.10)
Описание
Переполнение буфера в макрофункции HandleCoRREBBP в TightVNC позволяет злоумышленникам выполнить код, используя сетевое подключение.
Как исправить
Для устранения уязвимости необходимо установить последнюю версию продукта, соответствующую используемой платформе. Необходимую информацию можно получить по адресу:
https://www.tightvnc.com/
Ссылки
Источник: CVE
Наименование: CVE-2019-8287
URL: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8287

Переполнение буфера в динамической памяти Обход аутентификации