Расширенный
База уязвимостей

Переполнение буфера в динамической памяти

18 мая 2021
Уровень опасности
Оценка CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Производитель ПО
Наименование ПО
Foxit Reader (10.1.4.37651, 9.0.0.29935)
Описание
Переполнение буфера динамической памяти фиксированного размера в Foxit Reader, связанное с обработкой специально сформированного значения leadDigits в элементе Decimal, позволяет злоумышленникам, действующим удаленно, выполнить произвольный код в контексте текущего процесса, убедив пользователя открыть вредоносную страницу или вредоносный файл.
Как исправить
Для устранения уязвимости необходимо установить последнюю версию продукта, соответствующую используемой платформе. Необходимую информацию можно получить по адресу:
https://www.foxitsoftware.com/
Ссылки
Источник: CVE
Наименование: CVE-2021-31454
URL: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-31454