Расширенный

Разглашение информации

Разглашение информации

19 июля 2012
Уровень опасности
Оценка CVSS
(AV:N/AC:L/Au:N/C:N/I:C/A:N)
Производитель ПО
Наименование ПО
PHP (4.0.0, 4.4.7, 5.0.0RC, 5.2.2)
Описание
Функция mail в PHP обрезает e-mail-сообщения по первому ASCIIZ ('\0')-байту, что может позволить злоумышленникам препятствовать доставке сообщений. Замечание: эта проблема может быть связана с безопасностью в случаях, когда содержимое сообщения электронной почты является конфиденциальным и содержит, например, аутентификационную информацию, или если сообщение должно соответствовать определенному строгому формату.
Как исправить
Для устранения уязвимости необходимо установить последнюю версию продукта, соответствующую используемой платформе. Необходимую информацию можно получить по адресу:
http://www.php.net/
Ссылки