Расширенный

Обход ограничений безопасности

Обход ограничений безопасности

10 ноября 2014
Уровень опасности
Оценка CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
Производитель ПО
Наименование ПО
OpenSSL (0.9.0, 0.9.6m, 0.9.7, 0.9.7g, 0.9.8)
Описание
Реализация сервера SSL/TLS в OpenSSL при использовании опции SSL_OP_MSIE_SSLV2_RSA_PADDING отключает проверку, которая необходима для того, чтобы злоумышленник, действующий удаленно, не создать ситуацию, когда клиент и сервер используют младшую версию протокола, если стороны поддерживают более надежные, старшие версии. Для эксплуатации данной уязвимости используется атака "человек-посередине".
Как исправить
Для устранения уязвимости необходимо установить последнюю версию продукта, соответствующую используемой платформе. Необходимую информацию можно получить по адресу:
http://www.securityfocus.com/bid/15071/solution
Ссылки